There has been an error cropping your image

If you ever get an error while uploading and cropping an image on WordPress – Error like below

There has been an error cropping your image.

For this very blog when I was trying to upload an image to set it as a favicon I got this error

After searching for a while found that it was because GD library for PHP was not installed on the server

To find the GD Library package within CentOS repository

$ sudo yum list available | grep 'gd'
  • Save
List of Packages having ‘GD’ key-word under CentOS Repository

Identify GD Library package name and install it

$ sudo yum install php-gd
  • Save
GD library Dependencies Resolved

Restart apache service

$ sudo service httpd restart

Thank you for reading….
Hope It was of some help to you.

About the author

Rohan Kamble

I am a Web Developer by profession, who loves the web to the core with over 8 Years of Experience on working a wide range of domains like websites on e-commerce, matrimonial, company’s professional sites, Finance, company internal communications and many more…

View all posts

1 Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.